
Subject: Egypt DHS District Data
Posted by amira.elshal.1@city.ac.uk on Sun, 18 Aug 2013 00:11:49 GMT
View Forum Message <> Reply to Message

Dear Sirs,
 
In the results of Egypt's ever-married questionnaire of DHS 2008, how can I know to which district
an interviewed woman belong? I can check the governorate, but I cannot find the district. I need to
compare between reformed and non-reformed districts.
 
Thank you.
 
Sincerely,
Amira

Subject: Re: Egypt DHS District Data
Posted by Bridgette-DHS on Fri, 06 Sep 2013 12:59:20 GMT
View Forum Message <> Reply to Message

Here is a response from one of our Senior Data Processing Specialists, Noureddine Abderrahim:

Egypt DHS 2008 did not collect the district codes in the questionnaire.  You might want to check
with the implementing agency, to see if they still have the districts of the enumeration areas that
are included in the survey.  The address of the implementing agency can be found in the final
report of the survey which might be downloaded from the website.

Subject: Re: Egypt DHS District Data
Posted by amira.elshal.1@city.ac.uk on Thu, 06 Mar 2014 22:01:12 GMT
View Forum Message <> Reply to Message

Thank you for your kind reply.

Can I identify the district to which a questionned woman belong to using GPS data?

Thank you again.

Amira

Subject: Re: Egypt DHS District Data
Posted by user-rhs on Mon, 10 Mar 2014 19:39:28 GMT
View Forum Message <> Reply to Message
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Dear Amira,
You can join the woman to the GPS data via the cluster variable (v001 in the individual recode file,
and DHSCLUST in the GPS data--I think). Once you have joined the dataset, import it into your
GIS software of choice, and you can spatially merge the DHS cluster location points to whatever
administrative boundary layer(s) you have in GIS.  Note, though, as previously discussed on this
forum, the DHS cluster centroid points are only "guaranteed" to land on the correct DHS REGION
(variable v024) and not administrative levels below the region (i.e. district, subdistrict, etc.),
because these points are randomly displaced.  However, the documentation says the bias is quite
small.  I will post a link to the previous thread when I find it.

HTH,
RHS

UPDATE: Here's a previous thread about district names and confidentiality: 
http://userforum.dhsprogram.com/index.php?t=msg&th=36&am
p;goto=96&S=54389fca305f588b8b76cb6f5059eedf#msg_96

Here's another one that talks about displacement generally 
http://userforum.dhsprogram.com/index.php?t=msg&th=19&am
p;goto=30&S=54389fca305f588b8b76cb6f5059eedf#msg_30

Subject: Re: Egypt DHS District Data
Posted by amira.elshal.1@city.ac.uk on Tue, 11 Mar 2014 09:07:36 GMT
View Forum Message <> Reply to Message

I cannot thank you enough for your prompt reply.

The problem is that it is the first time I use GPS data to join individuals to particular administrative
divisions. So I need to be very carfeul.

Do you recommend any basic manuals to me to read? To teach me to import data to QGIS, etc?

Thank you again.

Amira

Subject: Re: Egypt DHS District Data
Posted by Josh-DHS on Tue, 11 Mar 2014 14:26:25 GMT
View Forum Message <> Reply to Message

Dear Amira,

For guidance on how to carry out a spatial join in QGIS and for information on our QGIS
curriculum, please see our response to your post on this forum thread 
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http://userforum.dhsprogram.com/index.php?t=rview&goto=1 532#msg_1532 .

If this has not answered your question adequately, please reply.

Josh

Subject: Re: Egypt DHS District Data
Posted by amira.elshal.1@city.ac.uk on Sun, 16 Mar 2014 13:10:42 GMT
View Forum Message <> Reply to Message

Dear Josh,

As I understand, I have to join the woman to the GPS data via the cluster variable (v001 in the
individual recode file and DHSCLUST in the GPS data) before importing it into your QGIS.

I now know how to import data to and use QGIS, but I do not know how to first join the woman to
the GPS data. I identified v001 in my .dta individual recode file and the DHSCLUST in the GPS
file but I fail to join them.

Please advise.

Thank you.

Amira

Subject: Re: Egypt DHS District Data
Posted by user-rhs on Sun, 16 Mar 2014 18:59:26 GMT
View Forum Message <> Reply to Message

Amira,
I'm not a QGIS user, so my explanation is how to do the join in ArcGIS.  I imagine the steps are
translatable to QGIS.  If you do not know how to do them in QGIS, consult the user manual or
help file for QGIS (http://www.qgis.org/en/docs/).

The way I would do it is to spatially join GIS data first in QGIS, and THEN once I have the district
info (from the spatial join), I would join with the rest of the DHS woman's recode file in my
statistical software.

To do this:

1. Join the GIS data spatially in QGIS.  When you download the GIS file from the DHS site, unzip
the entire folder into its own folder in the working directory.  It is crucial that your working folder
has all of the files in that zip file in there (file extensions DBF, PRJ, SBN, SBX, SHP, etc.),
because those files are what will allow you to plot the cluster centroids on your map. Here's a
screenshot of where I unzipped some Ethiopia DHS GIS files so I can spatially merge it with a
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layer that contains Woreda boundaries:

  

2. Open QGIS, and add the Egypt administrative boundary layers (province, district, etc.) that you
want to join to the DHS data.

3. Then import the data points into QGIS.

4. Spatially join the data points with the district layer.  You do a spatial join because there is no
identifier that is common to the district layer and your DHSGIS file that would allow you to join by
variable.

5. If you have the option of exporting the joined layer as a new layer or new shapefile, select that
option.  Make note of where the file will be saved, as the software will create all of the files
necessary to map that layer the next time  you open it in QGIS.

The next steps assume that QGIS creates a DBF file when you export a joined layer.  DBF is
basically where the data are stored.  This DBF file will contain the original variables in the
DHSGIS file in addition to the data from the boundary layer, namely, the district names you are
interested in.

  
6. Take the DBF (or however QGIS stores the data from the spatial join) and import it into your
statistical package (SAS, Stata, SPSS, etc.).  Rename DHSCLUST into v001 and sort by v001. 
Join with the DHS woman's recode file using the v001 variable, taking care to sort the woman's
recode file by v001 before joining w/ the DHS file.  

Opening the joined file in different packages:If you are a SAS user, you can import the DBF
directly using 

proc import out= dhs_geoc 
            datafile= "&loc.\JOINED FILE LOCATION\joined_file_name.dbf" 
            dbms=dbf replace;
run;
 If you are a Stata user, you should open the DBF in Excel, select the entire sheet, copy, and then
manually paste into a Stata data editor window.  

Since I don't work in SPSS unless I really have to, I can't tell you the exact steps, but I assume it's
fairly straightforward to open DBFs (file->open->change file type to "all", etc.).  Stata is the
stubborn one when it comes to opening files that are not "stata data file" format.

hth,
RHS

File Attachments
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1) gis_example.jpg, downloaded 1414 times

Subject: Re: Egypt DHS District Data
Posted by amira.elshal.1@city.ac.uk on Mon, 17 Mar 2014 11:37:57 GMT
View Forum Message <> Reply to Message

Dear RHS,

To spatially join GIS data first in QGIS, I first downloaded the GIS file from the DHS website and
unzipped the entire folder into its own folder in the working directory.

I then opened QGIS, pressed "ADD VECTOR LAYER", browsed to my GPS DHS 2008 folder,
selected EGGE5DFL.shp, then pressed open.

There appeared something like a map.

I then clicked Vector > Data Management Tools> Join attributes by location.

I am now supposed to set Target vector layer field to Cities_Settlements_0000 and set Join vector
layer to DHS_Regions. (See Attached File), but I could not. Both the target and the join vector
layer fields can only be set to EGGE5DFL.

Please advise.

Thank you.

Amira

File Attachments
1) Join Attributes by Location.docx, downloaded 707 times

Subject: Re: Egypt DHS District Data
Posted by amira.elshal.1@city.ac.uk on Mon, 17 Mar 2014 11:56:38 GMT
View Forum Message <> Reply to Message

Dear RHS,

I have to (1) first spatially join GIS data in QGIS, i.e. join the shapefile from Egypt's GPS DHS
folder AND the EGYPT GADM shapefile. Am I right?

The next step is to (2) import the output file of step (1) to STATA to merge it with the Egypt DHS
Woman's recode file. Is that correct?

Thank you very much. And apologies for disturbing you.

Page 5 of 8 ---- Generated from The DHS Program User Forum

https://userforum.dhsprogram.com/index.php?t=getfile&id=133
https://userforum.dhsprogram.com/index.php?t=usrinfo&id=994
https://userforum.dhsprogram.com/index.php?t=rview&th=389&goto=1600#msg_1600
https://userforum.dhsprogram.com/index.php?t=post&reply_to=1600
https://userforum.dhsprogram.com/index.php?t=getfile&id=134
https://userforum.dhsprogram.com/index.php?t=usrinfo&id=994
https://userforum.dhsprogram.com/index.php?t=rview&th=389&goto=1601#msg_1601
https://userforum.dhsprogram.com/index.php?t=post&reply_to=1601
https://userforum.dhsprogram.com/index.php


Amira

Subject: Re: Egypt DHS District Data
Posted by user-rhs on Mon, 17 Mar 2014 15:30:47 GMT
View Forum Message <> Reply to Message

Amira,
That is correct.  The data from your joined shapefile (the one that has the info from the DHS GIS
file PLUS the district names) is in the file with extension DBF (you can open this in Excel).  

You can get the DBF data into Stata following these steps:
http://www.ats.ucla.edu/stat/stata/faq/odbc.htm or what is described here (the part about
-insheet-):  http://www.stata.com/statalist/archive/2010-05/msg01004.html

or you can do what I do and open DBF in Excel-->Select all-->Copy, open Stata, type edit in the
command window and paste into the data editor window.  It should ask you whether you want to
treat the first row as variable names, in which case, you should choose that option.

Note: When you open the DBF file in Excel, make sure all of the rows have a value for
DHSCLUST so you can merge it in Stata.

RHS

Subject: Re: Egypt DHS District Data
Posted by user-rhs on Mon, 17 Mar 2014 18:13:23 GMT
View Forum Message <> Reply to Message

Quote:Dear RHS,

To spatially join GIS data first in QGIS, I first downloaded the GIS file from the DHS website and
unzipped the entire folder into its own folder in the working directory.

I then opened QGIS, pressed "ADD VECTOR LAYER", browsed to my GPS DHS 2008 folder,
selected EGGE5DFL.shp, then pressed open.

There appeared something like a map.

I then clicked Vector > Data Management Tools> Join attributes by location.

I am now supposed to set Target vector layer field to Cities_Settlements_0000 and set Join vector
layer to DHS_Regions. (See Attached File), but I could not. Both the target and the join vector
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layer fields can only be set to EGGE5DFL.

Please advise.

Thank you.

Amira

Amira, is "Cities_Settlements_0000" what you have named the layer with district boundaries?  If
you have both layers in there, you should be able to make the join.

RHS

Subject: Re: Egypt DHS District Data
Posted by amira.elshal.1@city.ac.uk on Wed, 19 Mar 2014 13:36:27 GMT
View Forum Message <> Reply to Message

One more question if you please: may you kindly advise on a reliable source from which I can
obtain Egypt's district names?

Thank you again.

Amira

Subject: Re: Egypt DHS District Data
Posted by user-rhs on Wed, 19 Mar 2014 14:30:31 GMT
View Forum Message <> Reply to Message

Egypt's ministry of health, national statistics agency, your own university may have resources. 
You should check with your supervisors.

Subject: Re: Egypt DHS District Data
Posted by amira.elshal.1@city.ac.uk on Fri, 21 Mar 2014 15:34:01 GMT
View Forum Message <> Reply to Message

Thank you very much.

The GIS polygon data of Egypt I imported from GADM only gives the governorate boundaries, not
the district boundaries  

I do have Egypt's district names, but not the district boundaries.
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Please advise.

Amira

Subject: Re: Egypt DHS District Data
Posted by user-rhs on Fri, 21 Mar 2014 21:50:00 GMT
View Forum Message <> Reply to Message

E-mail your university's geography department professors, development economics professors,
public health professors, etc. or do a Google search for Egypt district shapefiles.  That's what I
would do if I were in your situation.  Take advantage of the fact that you are still at university and
ask within your faculty.

It's also probably a good idea to schedule an appointment with someone in your university that
can show you how to get started using QGIS.  Good luck.
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